Exclusion do not work for removable drives

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
WXKK
Posts: 1
Joined: Fri Nov 09, 2018 8:02 am

Exclusion do not work for removable drives

Post by WXKK » Fri Nov 09, 2018 8:10 am

Exclusion do not work if I exclude drive X:/, which is removable. TrueCrypt drive, to be specific. I mount it and program starts to do something with it. Indexing, I guess. So I can't dismount. Then I go to Exclusions and see X:/ in list, which is ignored. I add one more exclusion, the same X:/ again, indexing stops and I can dismount now.

void
Site Admin
Posts: 4270
Joined: Fri Oct 16, 2009 11:31 pm

Re: Exclusion do not work for removable drives

Post by void » Sat Nov 10, 2018 7:24 am

Please try disabling automatically include new fixed volumes:
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Uncheck Automatically include new fixed volumes.
  • Select X: (if it is shown in the local NTFS volumes list)
  • Uncheck Include in database.
  • Click OK.
This will prevent Everything from automatically adding your X: drive to your index.

Adding volumes to the exclude list will not prevent Everything from indexing these volumes.
Everything also uses \ as a path separator, eg: X:\

Post Reply