Wildcards aren't working?

Found a bug in "Everything"? report it here
Post Reply
jdoe
Posts: 3
Joined: Wed Oct 13, 2010 9:33 pm

Wildcards aren't working?

Post by jdoe » Wed Oct 13, 2010 9:47 pm

I have Everything v.1.2.1.371.
All items in Search menu are unchecked.
I have a lot of files named IMG_<DIGITS>.JPG.
When I try to search files using "img*.jpg" (w/o quotes of course) I get no results. Same thing with "?" wildcard: "i?g" gives me nothing.
But simple pattern "img jpg" shows me my files.

void
Site Admin
Posts: 4207
Joined: Fri Oct 16, 2009 11:31 pm

Re: Wildcards aren't working?

Post by void » Thu Oct 14, 2010 1:35 am

Are there any results if you search for:
*img*.jpg*
*.jpg
*img*.jpg

jdoe
Posts: 3
Joined: Wed Oct 13, 2010 9:33 pm

Re: Wildcards aren't working?

Post by jdoe » Thu Oct 14, 2010 2:31 am

void wrote:Are there any results if you search for:*img*.jpg**.jpg*img*.jpg
Yeah! They do what they should do! It's a workaround to use "*" at the beginning?

therube
Posts: 1983
Joined: Thu Sep 03, 2009 6:48 pm

Re: Wildcards aren't working?

Post by therube » Thu Oct 14, 2010 4:34 am

It should be finding results.

Do you have, Search | Match Path enabled? If so, disable it.
For some reason it is affecting your search string, & I'm not really sure why?

Searching for xxx* anchors the search to find files that *start* with xxx.
(That is kind of odd, IMO.)

In any case, "img*.jpg" should find files that start with "img" & have an .jpg extension.
So: IMG00001.JPG, IMG00002.JPG, IMG00003.JPG, & also IMG_0001.JPG, IMG_0002.JPG, & IMG_0003.JPG

Searching for "img .jpg" will find the above plus: 001-IMG00001.JPG, 001-IMG00002.JPG, & 001-IMG00003.JPG


"i?g" ?
That says to find a three character file (or directory) that starts with "i" & ends with "g".
So in my case, it find a few directories named "IMG".


Support: Wildcards.

jdoe
Posts: 3
Joined: Wed Oct 13, 2010 9:33 pm

Re: Wildcards aren't working?

Post by jdoe » Fri Oct 15, 2010 9:02 am

I think I've got it!
Using "?" or "*" leads to consider our search string to be a template for whole file name (or whole path when Match Path is enabled) not its part.
Let me explain my statement: "Ado?e" searches only for files/folders wich have nothing but 5 letters a,d,o,any,e -- not for "Adobe Acrobat" (due to unmentioned " Acrobat"), not "Purchases plans for Adobe" (due to unmentioned "Purchases plans for "). Same here with "*": if I have enabled Match Path and use "img*.jpg" as search string I'll get no result (it is not mentioned path's part, eg: "d:\home\pics\"). Using "*img*.jpg" shows me files with jpg extention and with "img" in its name. But it could be "Retouched_IMG_0000.jpg" which appears in results too. If I want to specify to show only jpg-files wich name has "img" at the very beginning, I simply use backslash: "*\img*.jpg".

huckepick
Posts: 3
Joined: Mon Dec 06, 2010 12:57 am

Re: Wildcards aren't working?

Post by huckepick » Mon Dec 06, 2010 1:09 am

I have a similar problem but I couldn't translate your solution into one for my problem.

Given the case that I have files like this

a) ...\Desktop\master\anythingelse.svg and
b) ...\Desktop\yourmasterqueue.svg

I am interested in the file with "master" in the filename.
So I switch of "match path" and I type in the search:

master svg desktop\

So far everything is fine. I got my file.

When I type in:

master svg deskto*\

I got no valid results.

When I switch on "match path", I got both files in the result.

How to achieve finding only file b) without having to type in the full Foldername?

Cheers

deepdvd
Posts: 30
Joined: Mon Mar 23, 2009 6:35 pm

Re: Wildcards aren't working?

Post by deepdvd » Tue Dec 07, 2010 8:37 pm

huckepick wrote:I have a similar problem but I couldn't translate your solution into one for my problem.

Given the case that I have files like this

a) ...\Desktop\master\anythingelse.svg and
b) ...\Desktop\yourmasterqueue.svg

I am interested in the file with "master" in the filename.
So I switch of "match path" and I type in the search:

master svg desktop\

So far everything is fine. I got my file.

When I type in:

master svg deskto*\

I got no valid results.

When I switch on "match path", I got both files in the result.

How to achieve finding only file b) without having to type in the full Foldername?

Cheers
Simply put a / before the folder name
so your search above would be:
master svg /deskto

If you need the wildcard on the end, put the / at the end like you did. You don't need an asterisk *

huckepick
Posts: 3
Joined: Mon Dec 06, 2010 12:57 am

Re: Wildcards aren't working?

Post by huckepick » Wed Dec 08, 2010 12:03 am

Simply put a / before the folder name
so your search above would be:
master svg /deskto

If you need the wildcard on the end, put the / at the end like you did. You don't need an asterisk *
Thank you very much for your reply, deepdvd.

I think I didn't explain my point perfectly well.

When I type: master svg deskto\ (leaving out the asterisk as you suggested), I won't find my result.

Sure, typing: master svg desktop\ or : master svg desktop\ I'll be successful.

BUT in any case I have to be absolutely sure that the folder name I look for starts or ends with specific characters. I cannot simply type and arbitrary part of the folder name like: eskto\ and find \desktop\.

This very example is not really appropriate but there are lots of folders in my folder hierarchy in whose names I tried to describe the contents of the folder and I cannot reliably recall the beginning or ending of the name.

Take this example:

"git mercurial bazaar dvcs"

I remember two of the keywords but not which one was the first.

I'm just curious if Everything could find parts of names. That would be neat.

Because my only alternative I would use is Windows Desktop Search with a query like: svg master folder:*skto* NOT folder:master .
Unfortunately, that is not as quick as Everything (normally is and supposedly would be performing that task).
.....And speed is the reason why I use Everything.

deepdvd
Posts: 30
Joined: Mon Mar 23, 2009 6:35 pm

Re: Wildcards aren't working?

Post by deepdvd » Sat Dec 11, 2010 4:38 am

huckepick wrote:
Simply put a / before the folder name
so your search above would be:
master svg /deskto

If you need the wildcard on the end, put the / at the end like you did. You don't need an asterisk *
Thank you very much for your reply, deepdvd.

I think I didn't explain my point perfectly well.

When I type: master svg deskto\ (leaving out the asterisk as you suggested), I won't find my result.

Sure, typing: master svg desktop\ or : master svg desktop\ I'll be successful.

BUT in any case I have to be absolutely sure that the folder name I look for starts or ends with specific characters. I cannot simply type and arbitrary part of the folder name like: eskto\ and find \desktop\.

This very example is not really appropriate but there are lots of folders in my folder hierarchy in whose names I tried to describe the contents of the folder and I cannot reliably recall the beginning or ending of the name.

Take this example:

"git mercurial bazaar dvcs"

I remember two of the keywords but not which one was the first.

I'm just curious if Everything could find parts of names. That would be neat.

Because my only alternative I would use is Windows Desktop Search with a query like: svg master folder:*skto* NOT folder:master .
Unfortunately, that is not as quick as Everything (normally is and supposedly would be performing that task).
.....And speed is the reason why I use Everything.
In every one of your examples above, you put a backslash on the END, I mentioned to put it at the START for the example you gave. I completely understand what you wanted.

I realize you can't do a wildcard search in Everything for folders if you wanted to search for something like folder:*eskto*, but you can do a search for folders like folder:*esktop by doing "esktop/" or do a search like folder:deskto* by doing "/deskto" (I'm using a forward slash instead of a backslash, but it works either way)
I hope this makes sense this time.

huckepick
Posts: 3
Joined: Mon Dec 06, 2010 12:57 am

Re: Wildcards aren't working?

Post by huckepick » Sat Dec 11, 2010 1:40 pm

Thank you deepdvd.

That was what I wanted to be sure about: if there was something like *dkto* in EVERYTHING.

It's a helpful piece of software, anyway.

void
Site Admin
Posts: 4207
Joined: Fri Oct 16, 2009 11:31 pm

Re: Wildcards aren't working?

Post by void » Tue Mar 06, 2018 10:13 pm

To disable matching the whole filename when using wildcards:
  • In Everything, from the Tools menu, click Options.
  • Click the Search tab on the left.
  • Uncheck Match whole filename when using wildcards.
  • Click OK.
For using wildcards with regex, please see:
http://www.voidtools.com/support/everyt ... ing/#regex

bobm
Posts: 10
Joined: Fri Aug 21, 2015 11:27 am

Re: Wildcards aren't working?

Post by bobm » Wed Sep 05, 2018 10:50 am

@void
Thanks - this was the solution that worked for me on a recent installation.
Maybe it's worth switching that option off by default, as no matches when searching for string*string (rather than *string*string*) is not intuitive.

Post Reply