Page 1 of 1

Bug: directory search result vanishes if you create a shortcut to it

Posted: Sun Feb 10, 2019 7:15 pm
by Zavod
running up to date: Search Everything v1.4.1.877 (x64)

Organizing some photos, I was using SE to find some matching directories:

SearchString: 2018|2019 e:\album\photos !PhotosFromOthers scouts attrib:d

Then I'd drag one of the found directories to a NON-MATCHING destination, and create a SHORTCUT there.

The source directory immediately vanished from the search results. (I verified it still remained on the disk)

I then closed SE and re-opened, and pasted in the exact same search string (as above) and the missing directories returned.

This would happen both if I did the dragging-and-shortcut-creation from SE, or from a Windows Explorer window.

Repeatable.

Re: Bug: directory search result vanishes if you create a shortcut to it

Posted: Sun Feb 10, 2019 10:29 pm
by NotNull
You didn't mention your Everything version (or your Windows version), but there have been some updates in recent Everything verions regarding renaming files/folders.
Could you try if version 1.4.1.935 (or newer) solves your issue? It can be found here: viewtopic.php?t=5718


EDIT:
I think I misread your message ... But now I don't understand what you did. Did you move a folder in File Explorer and created a shortcut to that folder afterwards? :S
Anyway, please try version 1.4.1.935 :)

Re: Bug: directory search result vanishes if you create a shortcut to it

Posted: Mon Feb 11, 2019 10:48 am
by therube
Are you sure your search is correct?

Might you need:

Code: Select all

<2018|2019>  e:\album\photos  !PhotosFromOthers  scouts  attrib:d