Everything uses gigabytes of RAM

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
sanderg
Posts: 3
Joined: Sat Apr 04, 2009 6:47 pm

Everything uses gigabytes of RAM

Post by sanderg » Tue Sep 10, 2019 8:20 am

I tried to set up Everything 1.4.1.935 to index a disk with JPG files, about three levels deep. A few million files are stored on this disk. OS is Server 2012R2.

Even when setting Everything to the recommended values for memory optimization, the process starts using more than 2 GB memory. Additionally, the interface is not responding anymore after changing options, although the background process is still active and indexing the disk.

Is there a way to further reduce memory usage for Everything and keep it responsive as well?

NotNull
Posts: 1393
Joined: Wed May 24, 2017 9:22 pm

Re: Everything uses gigabytes of RAM

Post by NotNull » Tue Sep 10, 2019 2:14 pm

The more files you index, the bigger the database - on disk ànd in RAM - will get.
As you are only interested in JPG-files up to 3 levels deep, your best bet is to exclude files and folders from the database:

Only JPG files
  • Go to Menu:Tools > Options > Indexes > Exclude
  • Make sure Enable exclude list is enabled
  • in the Include only files: box enter
    *.jpg;*.gif

    (I added the *.gif to show the syntax if you want to add more filetypes; not needed for your question)
  • Save changes

Max 3 levels deep
  • Go to Menu:Tools > Options > Indexes > Exclude
  • Make sure Enable exclude list is enabled
  • Press the Add Filter button
  • Specify
    c:\*\*\*\*
    as your filter
    (replace c: with the actual disk)
    (You might have to add / remove one or more "\*" depending on your definition of 3 levels deep)
  • Save changes

Exclude entire disks
If you have entire disks you don't want to index, exclude those too. For each one of those disks:
  • Go to Menu:Tools > Options > Indexes > NTFS
  • In the Local NTFS volumes: box, select the disk you want to exclude
  • Disable Include in database for that disk.
  • Save settings

Succes ermee!


sanderg wrote:
Tue Sep 10, 2019 8:20 am
Everything 1.4.1.935
32 or 64-bit? (you should use 64-bit as 32-bit applications can't address more than 2GB RAM)

sanderg
Posts: 3
Joined: Sat Apr 04, 2009 6:47 pm

Re: Everything uses gigabytes of RAM

Post by sanderg » Thu Sep 12, 2019 10:28 am

Yes, it's the 64 bit version.

I set Everything up as you suggested. Except for the path filter, because the directory structure is just 3 levels deep anyway, so there is nothing to exclude.

When only indexing the modified date of *.jpg on a single disk and no other file properties, the interface stops responding when I again click Tools, Options. The background search process keeps growing in size - e.g. 1 GB within 10 minutes. I have no idea what the final RAM footprint is going to be to index all of the 300 GB.

I tried starting Wiztree at the same time, but it could not read from this disk - only after I force quit Everything. Then, Wiztree showed similar behaviour with regards to memory usage and slowness of scanning this disk.

Post Reply