Everything and Total Commander

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
Jill D Holloman
Posts: 1
Joined: Sun Mar 03, 2019 2:22 pm

Everything and Total Commander

Post by Jill D Holloman » Sun Mar 03, 2019 2:25 pm

Hi! My problem is this:
For every version of Everything after version (stable) I cannot make Everything search results (files or folders) open in Total Commander which I use and love
in conjuction with Everything. In version everything worked fine after adding these lines in everything.ini:

explore_folder_command=$exec("%SystemRoot%\explorer.exe" /n,/e,"%1")
explore_folder_path_command=$exec("%SystemRoot%\explorer.exe" /n,/e,/select,"%1")
open_folder_path_command=$exec("c:\totalcmd64\TOTALCMD64.EXE" /O /T "$parent(%1)")
open_file_command=$exec("c:\totalcmd64\TOTALCMD64.EXE" /O /T /L="%P" "%1")
open_folder_command=$exec("c:\totalcmd64\TOTALCMD64.EXE" /O /T "%1")

In newer versions the program seems to ignore the above lines.
I've tried adding them both to the installation folder (everything.ini) and the (newer?) %AppData% ini file with no success.
Any help is welcome.

Posts: 159
Joined: Thu Oct 27, 2016 7:19 pm

Re: Everything and Total Commander

Post by ovg » Sun Mar 03, 2019 4:02 pm

Try settings this via Tools->Options->Context Menu

In my ini I have:
You do not have the required permissions to view the files attached to this post.

Posts: 161
Joined: Fri Apr 04, 2014 3:24 pm

Re: Everything and Total Commander

Post by horst.epp » Sun Mar 03, 2019 5:37 pm

The following lines work fine for me with actual Everything Version (x64) and Total Commander 9.22rc1

open_folder_command2=$exec("c:\Tools\Wincmd\TOTALCMD64.EXE" /o /t /A /S "%1")
open_path_command2=$exec("c:\Tools\Wincmd\TOTALCMD64.EXE" /o /t /A /S "%1")
explore_command2=$exec("%SystemRoot%\explorer.exe" /n,/e,/select,"%1")
explore_path_command2=$exec("c:\Tools\Wincmd\TOTALCMD64.EXE" /o /t /S $parent("%1"))

But why don't you use the intergration of Everything in Total Commander itself ?

Post Reply