Can't see files when searching extensions

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
nokaoi
Posts: 1
Joined: Fri Jan 25, 2019 7:21 pm

Can't see files when searching extensions

Post by nokaoi » Fri Jan 25, 2019 7:28 pm

I must be missing something really easy, but I can't figure out what.

When I search for all files of an extension, I get no results. There are so many settings in options I'm not even sure what to tell you about.

If I use the Everything filter, and in that filter nothing is checked or entered in the text boxes, *.txt returns nothing.

If I use the default Documents filter, which lists a lot of extensions, and search for * I get no results.

What am I doing wrong?

vanisk
Posts: 76
Joined: Sat Oct 27, 2018 11:33 am

Re: Can't see files when searching extensions

Post by vanisk » Fri Jan 25, 2019 10:19 pm

Searching for * with no filters at all produces any result?

btw, by any chance, Search->Enable Regex is checked?

NotNull
Posts: 1054
Joined: Wed May 24, 2017 9:22 pm

Re: Can't see files when searching extensions

Post by NotNull » Sat Jan 26, 2019 9:13 pm

nokaoi wrote:
Fri Jan 25, 2019 7:28 pm
When I search for all files of an extension, [...]
How? (there are a lot of differnt ways to do this)

therube
Posts: 2054
Joined: Thu Sep 03, 2009 6:48 pm

Re: Can't see files when searching extensions

Post by therube » Sat Feb 02, 2019 1:24 pm

Yep, RegEx will probably do it.

Perhaps a "lite" mode install, where Ctrl+R shortcut is disabled by default, though left as grayed out in the menu (to indicate that it is available, by specifically "switching it on"?)

void
Site Admin
Posts: 4436
Joined: Fri Oct 16, 2009 11:31 pm

Re: Can't see files when searching extensions

Post by void » Sun Feb 03, 2019 5:19 am

Perhaps a "lite" mode install, where Ctrl+R shortcut is disabled by default, though left as grayed out in the menu (to indicate that it is available, by specifically "switching it on"?)
I like the idea of removing Ctrl + R.

A couple options come to mind:
Show the regex switch on the toolbar next to the search bar.

Reset the regex switch to off when showing a new search window.

Show a balloon notification above the REGEX status bar text that will not go away until you close it, with the following message:
REGEX enabled, double click to disable.
This would only be shown the first time regex is enabled.

NotNull
Posts: 1054
Joined: Wed May 24, 2017 9:22 pm

Re: Can't see files when searching extensions

Post by NotNull » Fri Feb 08, 2019 9:30 pm

The REGEX indicator is already on the status bar.
(That's how I enable/disable these options when in "mouse-mode": right-click the staus bar to enable an option; double-click a status bar indicator to disable it)

I think @therube's suggesion is based on quite a few threads where people accidentally press one of the Ctrl-<letter> keyboard shortcuts that causes unexpected search results?

void
Site Admin
Posts: 4436
Joined: Fri Oct 16, 2009 11:31 pm

Re: Can't see files when searching extensions

Post by void » Sat Feb 09, 2019 4:43 am

I have removed the following shortcut keys for the next major version of Everything:
Match Case (Ctrl + I)
Match Whole Word (Ctrl + B)
Match Path (Ctrl + U)
Match Diacritics (Ctrl + M)
Regex (Ctrl + R)
Always On Top (Ctrl + T)

I suspect these are rarely used. They can be manually re-added from Tools -> Options -> Keyboard.

NotNull
Posts: 1054
Joined: Wed May 24, 2017 9:22 pm

Re: Can't see files when searching extensions

Post by NotNull » Sat Feb 09, 2019 8:15 am

void wrote:
Sat Feb 09, 2019 4:43 am
I suspect these are rarely used. They can be manually re-added from Tools -> Options -> Keyboard.
Even I - "keyboard junkie" - never used them. (Alt-S gives overview what else is enabled/disabled; that prevents mistakes)

therube
Posts: 2054
Joined: Thu Sep 03, 2009 6:48 pm

Re: Can't see files when searching extensions

Post by therube » Sat Feb 09, 2019 1:04 pm

(Path, regularly. I'll add the shortcut back :-).
Regex, occasionally, but for that selecting from the menu is fine.)

Post Reply