Can see but not open

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
wienerp-ccc
Posts: 5
Joined: Thu Jan 24, 2019 7:07 pm

Can see but not open

Post by wienerp-ccc » Thu Jan 24, 2019 7:26 pm

Everything displays the contents of my NAS but when I double-click to open a file the following message is displayed: Windows cannot access <path is displayed as \\NASname\etc.).

After receiving this message, I have no problem accessing the contents of the NAS from File Explorer, so it is not a network issue.

Everything has no problem opening files on internal or USB drives.

Suggestions for correcting this issue will be appreciated.

Thanks

void
Site Admin
Posts: 4613
Joined: Fri Oct 16, 2009 11:31 pm

Re: Can see but not open

Post by void » Fri Jan 25, 2019 1:01 pm

Maybe a permission issue?

Please try running Everything as a standard user:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Everything service.
  • Uncheck Run as administrator.
  • Click OK.
  • Restart Everything (right click the Everything tray icon and click Exit).

wienerp-ccc
Posts: 5
Joined: Thu Jan 24, 2019 7:07 pm

Re: Can see but not open

Post by wienerp-ccc » Fri Jan 25, 2019 6:41 pm

Thanks for the reply and suggestion.

Unfortunately, Run As Administrator is already unchecked, and I reviewed this to verify.

Also, FYI, in Everything's properties screen, both my user profile and the administrators group (which my profile is a member of) has full control and all items are marked with a green check, so I don't think it is a permissions issue.

Admittedly, this is only a nuisance issue, as once I find a file I can always navigate to the path, but it would certainly be more convenient if Everything would open files on the NAS as it does with internal and USB-connected drives. This seems to be a network drive issue.

wienerp-ccc
Posts: 5
Joined: Thu Jan 24, 2019 7:07 pm

Re: Can see but not open

Post by wienerp-ccc » Fri Jan 25, 2019 6:50 pm

PROBLEM RESOLVED

I went to Everything > Options > Indexes > Folders and noticed that the folder was a network path (starting with \\....). As I also have this path mapped, I added a folder with the mapped drive letter, restarted Everything, and now when I double-click on a search result, the file is opened. I then removed the folder line starting with \\ to prevent double results. All is well now.

therube
Posts: 2157
Joined: Thu Sep 03, 2009 6:48 pm

Re: Can see but not open

Post by therube » Sat Jan 26, 2019 2:33 pm

What OS?
What version of Everything?
Which NAS?

Did you make a change to the Open (Files) Command: ?
(Tools | Options | General -> Context Menu ---> Open (Files))

Everything shouldn't have an issue with UNC paths, AFAIK?

wienerp-ccc
Posts: 5
Joined: Thu Jan 24, 2019 7:07 pm

Re: Can see but not open

Post by wienerp-ccc » Mon Jan 28, 2019 7:21 pm

Win 10 pro
Latest Everything ver
Buffalo TeraStation

wienerp-ccc
Posts: 5
Joined: Thu Jan 24, 2019 7:07 pm

Re: Can see but not open

Post by wienerp-ccc » Mon Jan 28, 2019 7:28 pm

Forgot your other queries

No cmd line changes
I also adjusted win security settings, including registry and group editor, none of which resolved the issue.
Seems to be a security issue, which is strange considering the problem doesn't show up elsewhere. oh well, setting Everything to use a mapped drive seems to have resolved the issue.

therube
Posts: 2157
Joined: Thu Sep 03, 2009 6:48 pm

Re: Can see but not open

Post by therube » Mon Jan 28, 2019 8:43 pm

(No issues here with UNC paths.
XP & Win10 1809)

Post Reply