Only one file shows in index.

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
BlackbirdCA
Posts: 1
Joined: Tue Oct 09, 2018 11:01 pm

Only one file shows in index.

Post by BlackbirdCA » Tue Oct 09, 2018 11:21 pm

Suddenly the index would show only one file, over and over again. And it began with "!..."( exclamation mark and filename.)
No other filenames would show.
When I entered a word in search, the file list went blank.

I removed" Everything" and removed all references and associated files to the program and reinstalled.

Worked for a few days then began the same routine, even though I had renamed the offending file to not include "!"

I'm puzzled, (and I didn't name the file with the "!")

Have again removed "Everything" but hope for a solution?

therube
Posts: 1982
Joined: Thu Sep 03, 2009 6:48 pm

Re: Only one file shows in index.

Post by therube » Tue Oct 09, 2018 11:53 pm

Check your settings under Search, including Filters.

dodiewhatsit
Posts: 1
Joined: Mon Oct 15, 2018 4:41 pm

Re: Only one file shows in index.

Post by dodiewhatsit » Mon Oct 15, 2018 4:43 pm

I get the same problem exactly

Unstinalled, reinstalled and it worked for a few days now only shows one particular file over and over again

did you get an answer?

Actuall I think I might install an earlier version, this never happened before

void
Site Admin
Posts: 4197
Joined: Fri Oct 16, 2009 11:31 pm

Re: Only one file shows in index.

Post by void » Tue Oct 16, 2018 9:04 am

This occurs when the Everything database is corrupt (partially filled with zeros).

Are you using any software to wipe temp files or app data?
Your Everything database is stored in a file called Everything.db and is usually located in %LOCALAPPDATA%\Everything

Is your C: drive an SSD?

Please try forcing a rebuild:
  • In Everything, from the Tools menu, click Options.
  • Click the Indexes tab on the left.
  • Click Force Rebuild.
  • Click OK.
Please try moving your Everything database location to another volume (if you have another volume):
  • In Everything, from the Tools menu, click Options.
  • Click the Indexes tab on the left.
  • Change Everything location to: D:\Everything
  • Click OK.
Please try the latest nightly build of Everything.

Post Reply