Everything doesn't start with Windows

If you are experiencing problems with "Everything", post here for assistance.
oblomov
Posts: 1
Joined: Fri Apr 07, 2017 10:19 am

Everything doesn't start with Windows

Postby oblomov » Fri Apr 07, 2017 10:30 am

Hi.
I have Win 10 64 bit. Everything doesn't start with Windows. I've set the right options in the program's preferences, but it just won't start at logon.
What should I do?
Thanks.

(Sorry for bad english) :D

void
Site Admin
Posts: 3126
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything doesn't start with Windows

Postby void » Fri Apr 07, 2017 10:36 am

Please make sure Run as administrator is disabled and the Everything service is enabled:
  • In "Everything", from the Tools menu, click Options.
  • Click the General tab.
  • Check Everything Service.
  • Uncheck Run as administrator.
  • Click OK.
  • Exit "Everything" (right click the Everything system tray icon and click Exit)
  • Restart Everything.

coderCK
Posts: 3
Joined: Wed Apr 12, 2017 8:35 pm

Re: Everything doesn't start with Windows

Postby coderCK » Thu Apr 13, 2017 3:27 pm

I'm having the same issue with Windows 10 x64, and I followed the instructions but it still doesn't work. I've even tried putting a shortcut to Everything in the Startup directory. What does happen when I follow the instructions is that the Everything service is running (in the task manager, I can see it in the Services tab, in the Processes tab under Background processes, and in the Details tab as Everything.exe), but there is no way for me to open a search window because there's no icon in the tray. So then I have to run the shortcut again (e.g. from the Start Menu), and then there will be two Everything.exe processes running, and I'll finally have my tray icon.

The weird thing about this is that it was working just fine for over a year, and then one day (within the past month or so) I started my computer and it was no longer in the tray. I don't remember changing any Windows configurations that would affect this, though there have been regular system updates. I should also note that this is with the Everything 1.3.4.686 Installer (64-bit). I have not tried the 32-bit installer, nor the 1.4.1 beta.

Any suggestions? I appreciate any help.

void
Site Admin
Posts: 3126
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything doesn't start with Windows

Postby void » Fri Apr 14, 2017 3:01 am

Is Start Everything on system startup checked in Everything:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab.
  • Is Start Everything on system startup checked or square-checked?

Is Everything still running as admin?
  • In Everything, press Ctrl + `
    Please look for the following line in the debug console starting with:
    IsAdmin
  • Is there a 1 or a 0 at the end of this line?

coderCK
Posts: 3
Joined: Wed Apr 12, 2017 8:35 pm

Re: Everything doesn't start with Windows

Postby coderCK » Fri Apr 14, 2017 3:29 am

In Everything, in the Options window, Start Everything on system startup is checked.
In the debug console, it says isAdmin 1.

coderCK
Posts: 3
Joined: Wed Apr 12, 2017 8:35 pm

Re: Everything doesn't start with Windows

Postby coderCK » Fri Apr 14, 2017 3:45 am

Since I saw in the console that it said isAdmin 1, I decided to investigate why it was running as admin even though the box was not checked in the options. Somehow, Everything.exe in Program Files\Everything had its properties set to run as administrator (I'm not sure how that got changed). I unchecked it in the file properties, restarted my computer, and it is running correctly again.

Thanks for your help!


Return to “Support”