(bug?) Don't show folders mapped to a drive letter (subst)

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
ponzonik
Posts: 6
Joined: Thu Apr 23, 2009 10:05 pm

(bug?) Don't show folders mapped to a drive letter (subst)

Post by ponzonik » Fri Nov 13, 2015 11:54 am

Somehow in Everything 1.3 I managed to list subst'ed folders just once. For instance, after running subst z: c:\users\myuser\downloads\, only the files in z: would show on Everything's search results. But now I made a clean install of Windows and Everything 1.4.0.709b, and I can't figure out how I managed to hide those folders the last time. Excluding c:\users\myuser\downloads\ also removes z: from the results.

Maybe it involved junctions....? I'm sure the answer is around here but I also can't find that... :/

Thanks!!
Last edited by ponzonik on Fri Nov 13, 2015 1:47 pm, edited 1 time in total.

ponzonik
Posts: 6
Joined: Thu Apr 23, 2009 10:05 pm

Re: Keep folders mapped to a drive letter (subst) off the se

Post by ponzonik » Fri Nov 13, 2015 1:47 pm

I've just checked on my work pc, where I have a similar setup with Windows 7 and Everything 1.3.3.658b (x86). I just added the original folder path to the exclude list, but the z: contents still show, so I suspect this is a regression. Maybe this should be moved to the bug reports subforum.

therube
Posts: 2098
Joined: Thu Sep 03, 2009 6:48 pm

Re: (bug?) Don't show folders mapped to a drive letter (subs

Post by therube » Fri Nov 13, 2015 11:29 pm

See if you don't have Z: also listed as a Folder or File Lists?

Options | Indexes -> Folders | File Lists

ponzonik
Posts: 6
Joined: Thu Apr 23, 2009 10:05 pm

Re: (bug?) Don't show folders mapped to a drive letter (subs

Post by ponzonik » Mon Nov 16, 2015 8:01 pm

No, nothing at all in either of those settings pages.

void
Site Admin
Posts: 4551
Joined: Fri Oct 16, 2009 11:31 pm

Re: (bug?) Don't show folders mapped to a drive letter (subs

Post by void » Tue Nov 17, 2015 9:33 am

Excluding c:\users\myuser\downloads\ also removes z: from the results.
There's a bug with 1.4.0.709b which will lose a subst index when rebuilding the database.

Please try forcing a rebuild from Tools -> Options -> Indexes. This should temporarily fix the issue.

I will have a fix soon.

void
Site Admin
Posts: 4551
Joined: Fri Oct 16, 2009 11:31 pm

Re: (bug?) Don't show folders mapped to a drive letter (subs

Post by void » Tue Nov 24, 2015 6:39 am

Excluding c:\users\myuser\downloads\ also removes z: from the results.
This issue should be fixed in Everything 1.4.0.713b

YossiD
Posts: 4
Joined: Wed Mar 01, 2017 1:00 pm

Re: (bug?) Don't show folders mapped to a drive letter (subst)

Post by YossiD » Tue Jan 01, 2019 3:15 pm

Using version 1.4.1.895 64-bit portable.

Recently migrated from Win XP to Win 10 64-bit (1803). In XP, local folders mapped to drive letter showed up fine in Everything (same version x86). Now in Win 10 64-bit, they don't.

Is this a known issue? Is there a workaround?

Thanks

NotNull
Posts: 1076
Joined: Wed May 24, 2017 9:22 pm

Re: (bug?) Don't show folders mapped to a drive letter (subst)

Post by NotNull » Tue Jan 01, 2019 7:57 pm

Perhaps you created the subst under a different account from the one you are running Everything from? (those subst's are per-user)
For example: you run Everything as administrator.

YossiD
Posts: 4
Joined: Wed Mar 01, 2017 1:00 pm

Re: (bug?) Don't show folders mapped to a drive letter (subst)

Post by YossiD » Wed Jan 09, 2019 1:14 pm

I have found a solution for Windows 10.

Instead of the subst command, I entered the mapping directly into the Windows registry under the following key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\DOS Devices

To map a local folder to a drive, create a new string value with the name of the value being the drive letter, and the value being the path. For an example, visit this website and look at Map a Folder to a Drive Letter Directly in the Registry, about half way down on this website.

I was having the same problem with other applications (e.g. IrfanView) and this registry edit fixed it there too. Interestingly, creating a .reg file to make this change didn't work, as Windows 10 would not accept the change and returned an error message, so I had to edit the registry manually.

Hope someone finds this helpful.

NotNull
Posts: 1076
Joined: Wed May 24, 2017 9:22 pm

Re: (bug?) Don't show folders mapped to a drive letter (subst)

Post by NotNull » Fri Jan 11, 2019 10:46 am

Thanks for this information!
And thanks for taking the time to share it with us. Appreciated!

Post Reply